Omni SDK - has anyone got it working?

Hi guys,

Has anyone tried to play around with Omni SDK that was just released? I followed all the steps but it didn't seem to work for me. I am a bit lost at Step 4, how do I reference those files and prefabs in the SDK package. Anyone can give some simple examples?

Thanks,
Shawn

Comments

  • AscensiAscensi Posts: 116
    I've requested that they refine the SDK Doc and it looks better but the SDK isn't working for me in Developer mode (without the Omni connected) It's supposed to allow mouse and keyboard use but what happens is the character is frozen - keyboard controls don't work. If I use a regular First person controller prefab it works fine. (Currently using Unity 5.4.2P3 on windows. ) I think there should be a video tutorial myself.

    This may help you
    1. Import the SteamVR package from the Unity Asset Store.
    2. In the Unity Project Tab, go to the Assets > OmniSDK > Prefabs folder, and click on the OmniControllerViveSetup prefab. This will allow you to edit this prefab in the Inspector tab.
    3. In the Inspector tab, find the Vive Camera Rig Prefab variable. For this variable, add a reference to the [CameraRig] prefab that can be found in the Assets > SteamVR > Prefabs folder.
    4. Edit the SteamVROmniController script. At the top, where it says //#define STEAMVR_OMNI, remove the two slashes to enable SteamVR support.

    I think after these steps we might need to get the JSON SDK for functionality with the Omni AND may be required for the developer mode to work although I would like it if someone could offer advice for the next step to at least get the developer mode working.
  • Ascensi, Thanks for the reply. I've done step 1-4 and it's not working with Omni connected. As you suggested, I might have to get the JSON SDK for it to work, although it doesn't seem that I need it to just walk around for testing purpose. I will give it a try!
  • Also, a video tutorial will be really helpful. Please consider doing it Virtuix!
  • AscensiAscensi Posts: 116
    Chokko713 said:

    Also, a video tutorial will be really helpful. Please consider doing it Virtuix!

    I've asked sutekiB if he is willing/interested in putting together a video tutorial and he said he's interested and has been meaning to try out the SDK so hopefully soon we'll have something! I think it's pretty essential to have something that shows the process fully to hopefully avoid any misunderstandings and get developers up to speed with less headaches as possible.
  • @Chokko713 Could you be more specific about what parts of the SDK you are struggling with? Are you using the Unity SDK or the UE4 SDK? The JSON SDK is not needed to make walking work.
  • AscensiAscensi Posts: 116

    @Chokko713 Could you be more specific about what parts of the SDK you are struggling with? Are you using the Unity SDK or the UE4 SDK? The JSON SDK is not needed to make walking work.

    Personally I'm using the Unity SDK and following the Doc my character doesn't work with the developer mode (keyboard controls)
  • I am using Unity SDK and these were the steps I took:

    1.Started a new project
    2. Import the SteamVR package from the Unity Asset Store and Omni SDK.
    3. In the Unity Project Tab, went to the Assets > OmniSDK > Prefabs folder, and click on the OmniControllerViveSetup prefab.
    4. In the Inspector tab, find the Vive Camera Rig Prefab variable. For this variable, add a reference to the [CameraRig] prefab that was found in the Assets > SteamVR > Prefabs folder.
    5. Edit the SteamVROmniController script. At the top, where it says //#define STEAMVR_OMNI, remove the two slashes to enable SteamVR support.
    6. Dragged the SteamVR Prefab (CamearRig) into the project.
    7. Built and Run the game. (using Window 86-64, Open VR since i am using HTC Vive)
    8. Tried to walk in Omni and it didnt work :(

    I followed the instruction pretty precisely. >_<

    Did I miss anything?

    Thanks!
  • Btw, does Room Scale set up affect anything? It's currently under Room Scale set up, Do i need to change it to standing?
  • AscensiAscensi Posts: 116
    Chokko713 said:

    I am using Unity SDK and these were the steps I took:

    1.Started a new project
    2. Import the SteamVR package from the Unity Asset Store and Omni SDK.
    3. In the Unity Project Tab, went to the Assets > OmniSDK > Prefabs folder, and click on the OmniControllerViveSetup prefab.
    4. In the Inspector tab, find the Vive Camera Rig Prefab variable. For this variable, add a reference to the [CameraRig] prefab that was found in the Assets > SteamVR > Prefabs folder.
    5. Edit the SteamVROmniController script. At the top, where it says //#define STEAMVR_OMNI, remove the two slashes to enable SteamVR support.
    6. Dragged the SteamVR Prefab (CamearRig) into the project.
    7. Built and Run the game. (using Window 86-64, Open VR since i am using HTC Vive)
    8. Tried to walk in Omni and it didnt work :(

    I followed the instruction pretty precisely. >_<

    Did I miss anything?

    Thanks!

    Did you install the JSON SDK? there is further instructions to make the Omni work with the computer.
  • NO I haven't, at this point I think the walking should have worked. I didn't want to go further since the basic function didn't even work. But I think I will try it anyways to see if it makes difference. But I don't think it has anything to do with the basic functions.
  • @Chokko713 You should not need the JSON SDK to get the walking to work. Do you have an Omni? If so, does Omni Connect show that everything is properly connected?

    Which player prefab do you have in your scene? Are you using one of our "Omni Prefab Runtime Switcher"?
  • @Chokko713 You should not need the JSON SDK to get the walking to work. Do you have an Omni? If so, does Omni Connect show that everything is properly connected?

    Which player prefab do you have in your scene? Are you using one of our "Omni Prefab Runtime Switcher"?

    yes I do have an omni and everything was connected properly.

    I wasn't using the "Omni Prefab Runtime Switcher", which I was confused about. The instruction did not mention anything about it. But I should add that script to my play object, correct?


  • ok, just put "OmniRuntimePrefabLoader" as my default player and now it works!!
  • So i did some testing after successfully setting up omni and walking, it seems like all the controls and feature of my player needs to custom before and save it as a prefab, then use it under the "Custom Setup Prefab" and check "Force loading Custom Prefab", but the rest like enemies, environments and all that can be set up just normally. Correct?
  • Yes, that sounds correct.
  • @Ascensi The developer mode is a different issue that we are currently trying to fix.
  • AscensiAscensi Posts: 116
    edited December 2016
    I finally got Developer mode to work, I had tested with making a plane surface and set the tag to "terrain". I was using the prefab in a Maze scene where there was no terrain layer tag. So this issue is likely about the physics layer. I unchecked some other settings to double check. So in "Edit". "project settings" and under "physics" disable the check mark box on default under "player".. the check boxes under player, all can remain checked except default. @Omni_Dev_Cameron After testing and confirming this, if there is no bug but maybe it's just standard procedure then maybe adding these specifics to the Doc may help to ensure that it works properly for others.

    The other cool thing I found out after I got this working is that I tried out the Vive Controller's track pad and wow! very handy, I can move with that if I decide I don't want to rely on the keyboard. The new Unity 5.5 update now presents themselves as standard joysticks so perhaps this was something not provided by the SDK? awesome regardless.
Sign In or Register to comment.