Omni SDK failed to work in UE4.12

MayDeathMayDeath Posts: 1
The Omni work well in games, but cant work in UE develop mode.

Comments

  • @MayDeath Sorry to hear it's not working. Can you provide more details on what wasn't working?
  • flashASAflashASA Posts: 5
    Same problem on UE 4.14, 4.15, 4.16.
    When I start compiled applications, plugin sent message to log file “Omni Found”, but after that sent “Failed to Read HID Data.”.
    Omni connected, steamVR working, last drivers, connection app and SDK files.
    Omniverse applications (like OmniArena) working well.
  • flashASAflashASA Posts: 5
    When I debug c++ code of plugin, I see RingAngle, RingDelta, GameX, GameY values at returned data has same data every time (0, 180, 127, 127), but quarterions, accelerometer and gyroscope data changes it's values...
  • @flashASA Are the Omni Tracking Pods turned on and connected to the shoes?
  • flashASAflashASA Posts: 5
    Yes, of course. And connection app see it. Moreover, when I move pods, data of quarterions, accelerometer and gyroscope changes activly.
  • MarkVMarkV Posts: 48
    Random question - is there a UE4 Blueprint available to work with the Omni ?
  • @flashASA Could you post a picture of Omni Connect with everything connected?
  • flashASAflashASA Posts: 5
    Everything works ONLY when device is "unsecured" by Omni team. BUT when it done, device is not compatible with Omniverse content. So sad...
  • Yes, that is the intended functionality. Can you explain to me how you are trying to use the Omni, and I can see how we can help?
  • flashASAflashASA Posts: 5
    Device was unsecured by your specialist with TeamViewer
Sign In or Register to comment.